SAP NetWeaver AS Java Invoker Servlet Code Execution (1445998)

critical Nessus Plugin ID 148399
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SAP NetWeaver AS Java server may be affected by code execution vulnerability

Description

SAP Netweaver Application Server Java versions before 7.30 are potentially affected by a code execution vulnerability in the invoker servlet.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Apply the appropriate patch according to the vendor advisory.

See Also

https://launchpad.support.sap.com/#/notes/1445998

Plugin Details

Severity: Critical

ID: 148399

File Name: sap_netweaver_as_1445998.nasl

Version: 1.4

Type: remote

Family: Web Servers

Published: 4/9/2021

Updated: 11/30/2021

Dependencies: sap_netweaver_as_web_detect.nbin

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2010-5326

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:sap:netweaver_application_server

Required KB Items: installed_sw/SAP Netweaver Application Server (AS), Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/13/2016

Vulnerability Publication Date: 5/13/2016

Reference Information

CVE: CVE-2010-5326