CVE-2010-5326

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before 7.3, does not require authentication, which allows remote attackers to execute arbitrary code via an HTTP or HTTPS request, as exploited in the wild in 2013 through 2016, aka a "Detour" attack.

References

https://www.onapsis.com/threat-report-tip-iceberg-wild-exploitation-cyber-attacks-sap-business-applications

http://www.onapsis.com/research/publications/sap-security-in-depth-vol4-the-invoker-servlet-a-dangerous-detour-into-sap-java-solutions

http://www.us-cert.gov/ncas/alerts/TA16-132A

http://www.securityfocus.com/bid/48925

http://service.sap.com/sap/support/notes/1445998

http://www.securityfocus.com/bid/90533

Details

Source: MITRE

Published: 2016-05-13

Updated: 2021-04-20

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 10

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Impact Score: 6

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:sap:netweaver_application_server_java:*:*:*:*:*:*:*:* versions up to 7.30 (inclusive)

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
148399SAP NetWeaver AS Java Invoker Servlet Code Execution (1445998)NessusWeb Servers
critical