Cisco IOS XR Software SNMP Management Plane Protection ACL Bypass (cisco-sa-snmp-7MKrW7Nq)

medium Nessus Plugin ID 148320
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 3.6

Synopsis

The remote device is missing a vendor-supplied security patch

Description

According to its self-reported version, IOS-XR is affected by a security bypass vulnerability due to incorrect LPTS programming when using SNMP with management plane protection. An unauthenticated, remote attacker can exploit this, by connecting to an affected device with SNMP, to connect to the device on the configured SNMP ports despite having a configuration to deny SNMP access. Valid credentials are required to execute any of the SNMP requests.

Please see the included Cisco BIDs and Cisco Security Advisory for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID CSCvt93184

See Also

http://www.nessus.org/u?a355528d

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvt93184

Plugin Details

Severity: Medium

ID: 148320

File Name: cisco-sa-snmp-7MKrW7Nq-iosxr.nasl

Version: 1.7

Type: combined

Family: CISCO

Published: 4/6/2021

Updated: 4/8/2021

Dependencies: cisco_ios_xr_version.nasl, cisco_enum_smu.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS Score Source: CVE-2021-1243

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:cisco:ios_xr

Required KB Items: Host/Cisco/IOS-XR/Version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/3/2021

Vulnerability Publication Date: 2/3/2021

Reference Information

CVE: CVE-2021-1243

CISCO-BUG-ID: CSCvt93184

CISCO-SA: cisco-sa-snmp-7MKrW7Nq

CWE: 284