Squid 2.x < 4.14 / 5.x < 5.0.5 (SQUID-2020:11)

high Nessus Plugin ID 148111
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote proxy server is affected by an HTTP Request Smuggling vulnerability

Description

According to its banner, the version of Squid running on the remote host is 2.x prior to 4.14 or 5.x prior to 5.0.5.
It is, therefore, affected by an HTTP request smuggling vulnerability due to improper input validation. This occurs for certain uri_whitespace in configuration settings. This problem allows a trusted client to perform HTTP Request Smuggling and access services otherwise forbidden by Squid security controls.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Squid version 4.14 or 5.05 or later.

See Also

http://www.nessus.org/u?94d2ab4c

Plugin Details

Severity: High

ID: 148111

File Name: squid_5_0_5.nasl

Version: 1.5

Type: remote

Family: Firewalls

Published: 3/25/2021

Updated: 4/1/2021

Dependencies: squid_version.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2020-25097

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.6

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/8/2021

Vulnerability Publication Date: 9/3/2020

Reference Information

CVE: CVE-2020-25097

IAVB: 2021-B-0021