Cisco SD-WAN Solution Privilege Escalation (cisco-sa-20190619-sdwan-privilescal)

high Nessus Plugin ID 147766
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote device is missing a vendor-supplied security patch

Description

According to its self-reported version, Cisco SD-WAN Solution vManage software is affected by a privilege escalation vulnerability in the web-based UI due to a failure to properly authorize certain user actions in the device configuration. An authenticated, remote attacker can exploit this to gain elevated privileges on an affected vManage device.

Please see the included Cisco BIDs and Cisco Security Advisory for more information

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID CSCvi69886

See Also

http://www.nessus.org/u?ed0412eb

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvi69886

Plugin Details

Severity: High

ID: 147766

File Name: cisco-sa-20190619-sdwan-privilescal.nasl

Version: 1.5

Type: local

Family: CISCO

Published: 3/15/2021

Updated: 3/16/2021

Dependencies: cisco_vedge_detect.nbin

Risk Information

CVSS Score Source: CVE-2019-1626

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:sd-wan_vmanage

Required KB Items: Cisco/Viptela/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 6/19/2019

Vulnerability Publication Date: 6/19/2019

Reference Information

CVE: CVE-2019-1626