Webmin 1.890 XSS

medium Nessus Plugin ID 146497

Synopsis

The remote web server is affected by a cross-site scripting vulnerability.

Description

A cross-site scripting (XSS) vulnerability exists in Webmin 1.890 due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Webmin 1.900 or later.

See Also

http://www.webmin.com/changes.html

http://www.webmin.com/security.html

Plugin Details

Severity: Medium

ID: 146497

File Name: webmin_1_900.nasl

Version: 1.2

Type: remote

Published: 2/16/2021

Updated: 2/19/2021

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.7

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2018-19191

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/21/2019

Vulnerability Publication Date: 3/21/2019

Reference Information

CVE: CVE-2018-19191