pfSense < 2.4.5 Multiple Vulnerabilities

critical Nessus Plugin ID 146433


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is to 2.4.5. It is, therefore, affected by multiple vulnerabilities, including the following:

- In pfSense 2.4.4-p2 and 2.4.4-p3, if it is possible to trick an authenticated administrator into clicking on a button on a phishing page, an attacker can leverage XSS to upload arbitrary executable code, via diag_command.php and rrd_fetch_json.php (timePeriod parameter), to a server. Then, the remote attacker can run any command with root privileges on that server. (CVE-2019-12949)

- An XSS issue was discovered in pfSense through 2.4.4-p3. In services_captiveportal_mac.php, the username and delmac parameters are displayed without sanitization. (CVE-2019-16914)

- An issue was discovered in pfSense through 2.4.4-p3. widgets/widgets/picture.widget.php uses the widgetkey parameter directly without sanitization (e.g., a basename call) for a pathname to file_get_contents or file_put_contents. (CVE-2019-16915)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to pfSense version 2.4.5 or later, or apply patches as noted in the vendor advisory.

See Also

Plugin Details

Severity: Critical

ID: 146433

File Name: pfsense_2_4_5.nasl

Version: 1.3

Type: remote

Family: Firewalls

Published: 2/11/2021

Updated: 1/22/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-16915


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/17/2020

Vulnerability Publication Date: 1/17/2020

Reference Information

CVE: CVE-2019-12462, CVE-2019-12949, CVE-2019-16914, CVE-2019-16915