pfSense < 2.4.5 Multiple Vulnerabilities

high Nessus Plugin ID 146433
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is to 2.4.5. It is, therefore, affected by multiple vulnerabilities, including the following:

- In pfSense 2.4.4-p2 and 2.4.4-p3, if it is possible to trick an authenticated administrator into clicking on a button on a phishing page, an attacker can leverage XSS to upload arbitrary executable code, via diag_command.php and rrd_fetch_json.php (timePeriod parameter), to a server. Then, the remote attacker can run any command with root privileges on that server. (CVE-2019-12949)

- An XSS issue was discovered in pfSense through 2.4.4-p3. In services_captiveportal_mac.php, the username and delmac parameters are displayed without sanitization. (CVE-2019-16914)

- An issue was discovered in pfSense through 2.4.4-p3. widgets/widgets/picture.widget.php uses the widgetkey parameter directly without sanitization (e.g., a basename call) for a pathname to file_get_contents or file_put_contents. (CVE-2019-16915)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to pfSense version 2.4.5 or later, or apply patches as noted in the vendor advisory.

See Also

https://docs.netgate.com/pfsense/en/latest/releases/2-4-5.html

http://www.nessus.org/u?1016ba4d

http://www.nessus.org/u?585c5ae8

http://www.nessus.org/u?82bd096d

http://www.nessus.org/u?3f44e91d

http://www.nessus.org/u?d7044ef9

http://www.nessus.org/u?a2d565cd

http://www.nessus.org/u?6be62679

Plugin Details

Severity: High

ID: 146433

File Name: pfsense_2_4_5.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 2/11/2021

Updated: 2/12/2021

Dependencies: pfsense_detect.nbin

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2019-16915

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

Required KB Items: Host/pfSense

Exploit Ease: No known exploits are available

Patch Publication Date: 1/17/2020

Vulnerability Publication Date: 1/17/2020

Reference Information

CVE: CVE-2019-12462, CVE-2019-12949, CVE-2019-16914, CVE-2019-16915