pfSense 2.4.x < 2.4.5-p1 Multiple Vulnerabilities

high Nessus Plugin ID 146206

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version 2.4.x prior to 2.4.5-p1. It is, therefore, affected by the following vulnerabilities in its subcomponents:

- Unbound before 1.10.1 has Insufficient Control of Network Message Volume, aka an 'NXNSAttack' issue. This is triggered by random subdomains in the NSDNAME in NS records. (CVE-2020-12662)

- Unbound before 1.10.1 has an infinite loop via malformed DNS answers received from upstream servers.
(CVE-2020-12663)

- json-c through 0.14 has an integer overflow and out-of-bounds write via a large JSON file, as demonstrated by printbuf_memappend. (CVE-2020-12762)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to pfSense version 2.4.5-p1 or later, or apply patches as noted in the vendor advisory.

See Also

https://docs.netgate.com/pfsense/en/latest/releases/2-4-5-p1.html

Plugin Details

Severity: High

ID: 146206

File Name: pfsense_2_4_5_p1.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 2/4/2021

Updated: 2/5/2021

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-12762

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

Required KB Items: Host/pfSense

Exploit Ease: No known exploits are available

Patch Publication Date: 6/9/2020

Vulnerability Publication Date: 5/9/2020

Reference Information

CVE: CVE-2020-12662, CVE-2020-12663, CVE-2020-12762