pfSense 2.4.x < 2.4.4-p1 Multiple Vulnerabilities (SA-18_09)

high Nessus Plugin ID 146059
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version 2.4.x prior to 2.4.4-p1. It is, therefore, affected by multiple vulnerabilities, including the following:

- An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_normal_mode` parameter. (CVE-2018-4019)

- An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_ac_mode` POST parameter parameter. (CVE-2018-4020)

- An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_battery_mode` POST parameter. (CVE-2018-4021)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to pfSense version 2.4.4-p1 or later, or apply patches as noted in the vendor advisory.

See Also

http://www.nessus.org/u?a654a213

https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p1.html

Plugin Details

Severity: High

ID: 146059

File Name: pfsense_2_4_4_p1.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 2/2/2021

Updated: 2/3/2021

Dependencies: pfsense_detect.nbin

Risk Information

CVSS Score Source: CVE-2018-4019

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense, cpe:/a:netgate:pfsense

Required KB Items: Host/pfSense

Exploit Ease: No known exploits are available

Patch Publication Date: 11/15/2018

Vulnerability Publication Date: 9/28/2018

Reference Information

CVE: CVE-2018-4019, CVE-2018-4020, CVE-2018-4021, CVE-2018-6925, CVE-2018-17154, CVE-2018-17155