CentOS 8 : kernel (CESA-2019:3517)

high Nessus Plugin ID 145665
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 7.7

Synopsis

The remote CentOS host is missing one or more security updates.

Description

The remote CentOS Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the CESA-2019:3517 advisory.

- kernel: Linux stack ASLR implementation Integer overflow (CVE-2015-1593)

- kernel: nfs: use-after-free in svc_process_common() (CVE-2018-16884)

- kernel: Information Disclosure in crypto_report_one in crypto/crypto_user.c (CVE-2018-19854)

- kernel: oob memory read in hso_probe in drivers/net/usb/hso.c (CVE-2018-19985)

- kernel: usb: missing size check in the __usb_get_extra_descriptor() leading to DoS (CVE-2018-20169)

- kernel: Heap overflow in mwifiex_uap_parse_tail_ies function in drivers/net/wireless/marvell/mwifiex/ie.c (CVE-2019-10126)

- kernel: null-pointer dereference in hci_uart_set_flow_control (CVE-2019-10207)

- Kernel: net: weak IP ID generation leads to remote device tracking (CVE-2019-10638)

- kernel: fix race condition between mmget_not_zero()/get_task_mm() and core dumping (CVE-2019-11599)

- kernel: fs/ext4/extents.c leads to information disclosure (CVE-2019-11833)

- kernel: sensitive information disclosure from kernel stack memory via HIDPCONNADD command (CVE-2019-11884)

- kernel: unchecked kstrdup of fwstr in drm_load_edid_firmware leads to denial of service (CVE-2019-12382)

- kernel: use-after-free in arch/x86/lib/insn-eval.c (CVE-2019-13233)

- kernel: denial of service in arch/powerpc/kernel/signal_32.c and arch/powerpc/kernel/signal_64.c via sigreturn() system call (CVE-2019-13648)

- Kernel: KVM: OOB memory access via mmio ring buffer (CVE-2019-14821)

- kernel: out-of-bounds array access in __xfrm_policy_unlink (CVE-2019-15666)

- kernel: memory leak in register_queue_kobjects() in net/core/net-sysfs.c leads to denial of service (CVE-2019-15916)

- kernel: memory leak in genl_register_family() in net/netlink/genetlink.c (CVE-2019-15921)

- kernel: null pointer dereference in drivers/net/ethernet/intel/fm10k/fm10k_main.c (CVE-2019-15924)

- kernel: Memory leak in sit_init_net() in net/ipv6/sit.c (CVE-2019-16994)

- kernel: Heap address information leak while using L2CAP_GET_CONF_OPT (CVE-2019-3459)

- kernel: Heap address information leak while using L2CAP_PARSE_CONF_RSP (CVE-2019-3460)

- kernel: SCTP socket buffer memory leak leading to denial of service (CVE-2019-3874)

- kernel: denial of service vector through vfio DMA mappings (CVE-2019-3882)

- Kernel: vhost_net: infinite loop while receiving packets leads to DoS (CVE-2019-3900)

- Kernel: page cache side channel attacks (CVE-2019-5489)

- Kernel: KVM: leak of uninitialized stack contents to guest (CVE-2019-7222)

- hardware: bluetooth: BR/EDR encryption key negotiation attacks (KNOB) (CVE-2019-9506)

- kernel: use-after-free read in napi_gro_frags() in the Linux kernel (CVE-2020-10720)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2019:3517

Plugin Details

Severity: High

ID: 145665

File Name: centos8_RHSA-2019-3517.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/29/2021

Updated: 3/23/2021

Dependencies: ssh_get_info.nasl, linux_alt_patch_detect.nasl

Risk Information

Risk Factor: High

VPR Score: 7.7

CVSS Score Source: CVE-2019-10126

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:centos:centos:8, p-cpe:/a:centos:centos:bpftool, p-cpe:/a:centos:centos:kernel, p-cpe:/a:centos:centos:kernel-abi-whitelists, p-cpe:/a:centos:centos:kernel-core, p-cpe:/a:centos:centos:kernel-cross-headers, p-cpe:/a:centos:centos:kernel-debug, p-cpe:/a:centos:centos:kernel-debug-core, p-cpe:/a:centos:centos:kernel-debug-devel, p-cpe:/a:centos:centos:kernel-debug-modules, p-cpe:/a:centos:centos:kernel-debug-modules-extra, p-cpe:/a:centos:centos:kernel-devel, p-cpe:/a:centos:centos:kernel-headers, p-cpe:/a:centos:centos:kernel-modules, p-cpe:/a:centos:centos:kernel-modules-extra, p-cpe:/a:centos:centos:kernel-tools, p-cpe:/a:centos:centos:kernel-tools-libs, p-cpe:/a:centos:centos:kernel-tools-libs-devel, p-cpe:/a:centos:centos:perf, p-cpe:/a:centos:centos:python3-perf

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/5/2019

Vulnerability Publication Date: 2/13/2015

Reference Information

CVE: CVE-2015-1593, CVE-2018-16884, CVE-2018-19854, CVE-2018-19985, CVE-2018-20169, CVE-2019-3459, CVE-2019-3460, CVE-2019-3874, CVE-2019-3882, CVE-2019-3900, CVE-2019-5489, CVE-2019-7222, CVE-2019-9506, CVE-2019-10126, CVE-2019-10207, CVE-2019-10638, CVE-2019-11599, CVE-2019-11833, CVE-2019-11884, CVE-2019-12382, CVE-2019-13233, CVE-2019-13648, CVE-2019-14821, CVE-2019-15666, CVE-2019-15916, CVE-2019-15921, CVE-2019-15924, CVE-2019-16994, CVE-2020-10720

BID: 72607, 106148, 106253, 106478, 106565, 106963, 107488, 107528, 107782, 107910, 108076, 108113, 108299, 108372, 108474, 108817, 109055, 109092

RHSA: 2019:3517