CentOS 8 : thunderbird (CESA-2019:1308)

high Nessus Plugin ID 145630
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote CentOS host is missing one or more security updates.

Description

The remote CentOS Linux 8 host has a package installed that is affected by multiple vulnerabilities as referenced in the CESA-2019:1308 advisory.

- mozilla: Cross-origin theft of images with ImageBitmapRenderingContext (CVE-2018-18511)

- Mozilla: Use-after-free in XMLHttpRequest (CVE-2019-11691)

- Mozilla: Use-after-free removing listeners in the event listener manager (CVE-2019-11692)

- Mozilla: Buffer overflow in WebGL bufferdata on Linux (CVE-2019-11693)

- Mozilla: Theft of user history data through drag and drop of hyperlinks to and from bookmarks (CVE-2019-11698)

- chromium-browser: Out of bounds read in Skia (CVE-2019-5798)

- libpng: use-after-free in png_image_free in png.c (CVE-2019-7317)

- Mozilla: Cross-origin theft of images with createImageBitmap (CVE-2019-9797)

- Mozilla: Memory safety bugs fixed in Firefox 67 and Firefox ESR 60.7 (CVE-2019-9800)

- Mozilla: Stealing of cross-domain images using canvas (CVE-2019-9817)

- Mozilla: Compartment mismatch with fetch API (CVE-2019-9819)

- Mozilla: Use-after-free of ChromeEventHandler by DocShell (CVE-2019-9820)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected thunderbird package.

See Also

https://access.redhat.com/errata/RHSA-2019:1308

Plugin Details

Severity: High

ID: 145630

File Name: centos8_RHSA-2019-1308.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/29/2021

Updated: 3/23/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS Score Source: CVE-2019-9820

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:centos:centos:8, p-cpe:/a:centos:centos:thunderbird

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 6/3/2019

Vulnerability Publication Date: 1/25/2019

Reference Information

CVE: CVE-2018-18511, CVE-2019-5798, CVE-2019-7317, CVE-2019-9797, CVE-2019-9800, CVE-2019-9817, CVE-2019-9819, CVE-2019-9820, CVE-2019-11691, CVE-2019-11692, CVE-2019-11693, CVE-2019-11698

BID: 107009, 107363, 107486, 108098, 108418

RHSA: 2019:1308