Scientific Linux Security Update : firefox on SL7.x i686/x86_64 (2021:0290)

high Nessus Plugin ID 145504

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

The remote Scientific Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the SLSA-2021:0290-1 advisory.

- Mozilla: Cross-origin information leakage via redirected PDF requests (CVE-2021-23953)

- Mozilla: Type confusion when using logical assignment operators in JavaScript switch statements (CVE-2021-23954)

- Mozilla: Memory safety bugs fixed in Firefox 85 and Firefox ESR 78.7 (CVE-2021-23964)

- Mozilla: HTTPS pages could have been intercepted by a registered service worker when they should not have been (CVE-2020-26976)

- Mozilla: Use-after-poison for incorrectly redeclared JavaScript variables during GC (CVE-2021-23960)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected firefox and / or firefox-debuginfo packages.

See Also

https://www.scientificlinux.org/category/sl-errata/slsa-20210290-1

Plugin Details

Severity: High

ID: 145504

File Name: sl_20210127_firefox_on_SL7_x.nasl

Version: 1.6

Type: local

Agent: unix

Published: 1/27/2021

Updated: 3/4/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-23960

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:2.3:a:fermilab:scientific_linux:firefox:*:*:*:*:*:*:*, p-cpe:2.3:a:fermilab:scientific_linux:firefox-debuginfo:*:*:*:*:*:*:*, cpe:2.3:o:fermilab:scientific_linux:*:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 1/27/2021

Vulnerability Publication Date: 1/7/2021

Reference Information

CVE: CVE-2020-26976, CVE-2021-23953, CVE-2021-23954, CVE-2021-23960, CVE-2021-23964

RHSA: RHSA-2021:0290

IAVA: 2021-A-0051-S