CVE-2020-26976

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

When a HTTPS pages was embedded in a HTTP page, and there was a service worker registered for the former, the service worker could have intercepted the request for the secure page despite the iframe not being a secure context due to the (insecure) framing. This vulnerability affects Firefox < 84.

References

https://bugzilla.mozilla.org/show_bug.cgi?id=1674343

https://lists.debian.org/debian-lts-announce/2021/02/msg00001.html

https://lists.debian.org/debian-lts-announce/2021/02/msg00002.html

https://security.gentoo.org/glsa/202102-02

https://www.debian.org/security/2021/dsa-4840

https://www.debian.org/security/2021/dsa-4842

https://www.mozilla.org/security/advisories/mfsa2020-54/

Details

Source: MITRE

Published: 2021-01-07

Updated: 2021-02-15

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 6.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (44 total)

IDNameProductFamilySeverity
154553NewStart CGSL CORE 5.04 / MAIN 5.04 : thunderbird Multiple Vulnerabilities (NS-SA-2021-0094)NessusNewStart CGSL Local Security Checks
high
154552NewStart CGSL CORE 5.04 / MAIN 5.04 : firefox Multiple Vulnerabilities (NS-SA-2021-0094)NessusNewStart CGSL Local Security Checks
high
154489NewStart CGSL MAIN 6.02 : firefox Multiple Vulnerabilities (NS-SA-2021-0120)NessusNewStart CGSL Local Security Checks
high
154475NewStart CGSL MAIN 6.02 : thunderbird Multiple Vulnerabilities (NS-SA-2021-0119)NessusNewStart CGSL Local Security Checks
high
154471NewStart CGSL CORE 5.05 / MAIN 5.05 : thunderbird Multiple Vulnerabilities (NS-SA-2021-0177)NessusNewStart CGSL Local Security Checks
high
154451NewStart CGSL CORE 5.05 / MAIN 5.05 : firefox Multiple Vulnerabilities (NS-SA-2021-0178)NessusNewStart CGSL Local Security Checks
high
150562SUSE SLES11 Security Update : MozillaFirefox (SUSE-SU-2021:14609-1)NessusSuSE Local Security Checks
high
146634Amazon Linux 2 : thunderbird (ALAS-2021-1603)NessusAmazon Linux Local Security Checks
high
146565Oracle Linux 8 : thunderbird (ELSA-2021-0298)NessusOracle Linux Local Security Checks
high
146538Ubuntu 20.10 : Thunderbird vulnerabilities (USN-4736-1)NessusUbuntu Local Security Checks
high
146513openSUSE Security Update : MozillaFirefox (openSUSE-2021-222)NessusSuSE Local Security Checks
high
146163Debian DLA-2539-1 : firefox-esr security updateNessusDebian Local Security Checks
high
146162openSUSE Security Update : MozillaFirefox (openSUSE-2021-223)NessusSuSE Local Security Checks
high
146155Debian DLA-2541-1 : thunderbird security updateNessusDebian Local Security Checks
high
146095RHEL 8 : thunderbird (RHSA-2021:0397)NessusRed Hat Local Security Checks
high
146051SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2021:0259-1)NessusSuSE Local Security Checks
high
145792CentOS 8 : firefox (CESA-2021:0288)NessusCentOS Local Security Checks
high
145791CentOS 8 : thunderbird (CESA-2021:0298)NessusCentOS Local Security Checks
high
145768openSUSE Security Update : MozillaThunderbird (openSUSE-2021-208)NessusSuSE Local Security Checks
high
145765SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2021:0246-1)NessusSuSE Local Security Checks
high
145758GLSA-202102-02 : Mozilla Thunderbird: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
145746openSUSE Security Update : MozillaThunderbird (openSUSE-2021-209)NessusSuSE Local Security Checks
high
145739SUSE SLES12 Security Update : MozillaFirefox (SUSE-SU-2021:0241-1)NessusSuSE Local Security Checks
high
145728Debian DSA-4842-1 : thunderbird - security updateNessusDebian Local Security Checks
high
145697Scientific Linux Security Update : thunderbird on SL7.x x86_64 (2021:0297)NessusScientific Linux Local Security Checks
high
145545RHEL 7 : thunderbird (RHSA-2021:0297)NessusRed Hat Local Security Checks
high
145544RHEL 7 : firefox (RHSA-2021:0290)NessusRed Hat Local Security Checks
high
145543RHEL 8 : thunderbird (RHSA-2021:0298)NessusRed Hat Local Security Checks
high
145541RHEL 8 : thunderbird (RHSA-2021:0299)NessusRed Hat Local Security Checks
high
145540Oracle Linux 7 : thunderbird (ELSA-2021-0297)NessusOracle Linux Local Security Checks
high
145539Oracle Linux 8 : firefox (ELSA-2021-0288)NessusOracle Linux Local Security Checks
high
145527Debian DSA-4840-1 : firefox-esr - security updateNessusDebian Local Security Checks
high
145508Oracle Linux 7 : firefox (ELSA-2021-0290)NessusOracle Linux Local Security Checks
high
145507RHEL 8 : firefox (RHSA-2021:0288)NessusRed Hat Local Security Checks
high
145506RHEL 8 : firefox (RHSA-2021:0289)NessusRed Hat Local Security Checks
high
145504Scientific Linux Security Update : firefox on SL7.x i686/x86_64 (2021:0290)NessusScientific Linux Local Security Checks
high
145503RHEL 8 : firefox (RHSA-2021:0285)NessusRed Hat Local Security Checks
high
145468Mozilla Thunderbird < 78.7NessusWindows
high
145467Mozilla Thunderbird < 78.7NessusMacOS X Local Security Checks
high
145447Mozilla Firefox ESR < 78.7NessusMacOS X Local Security Checks
high
145446Mozilla Firefox ESR < 78.7NessusWindows
high
144299Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : Firefox vulnerabilities (USN-4671-1)NessusUbuntu Local Security Checks
critical
144283Mozilla Firefox < 84.0NessusMacOS X Local Security Checks
critical
144282Mozilla Firefox < 84.0NessusWindows
critical