openSUSE Security Update : slurm_18_08 (openSUSE-2020-2286)

medium Nessus Plugin ID 145334
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for slurm_18_08 fixes the following issues :

Security issues fixed :

- CVE-2020-27745: Fixed a potential buffer overflow from use of unpackmem (bsc#1178890).

- CVE-2020-27746: Fixed a potential leak of the magic cookie when sent as an argument to the xauth command (bsc#1178891).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected slurm_18_08 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1178890

https://bugzilla.opensuse.org/show_bug.cgi?id=1178891

Plugin Details

Severity: Medium

ID: 145334

File Name: openSUSE-2020-2286.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/25/2021

Updated: 2/2/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpmi0, p-cpe:/a:novell:opensuse:libpmi0-debuginfo, p-cpe:/a:novell:opensuse:libslurm33, p-cpe:/a:novell:opensuse:libslurm33-debuginfo, p-cpe:/a:novell:opensuse:perl-slurm, p-cpe:/a:novell:opensuse:perl-slurm-debuginfo, p-cpe:/a:novell:opensuse:slurm, p-cpe:/a:novell:opensuse:slurm-auth-none, p-cpe:/a:novell:opensuse:slurm-auth-none-debuginfo, p-cpe:/a:novell:opensuse:slurm-config, p-cpe:/a:novell:opensuse:slurm-config-man, p-cpe:/a:novell:opensuse:slurm-cray, p-cpe:/a:novell:opensuse:slurm-cray-debuginfo, p-cpe:/a:novell:opensuse:slurm-debuginfo, p-cpe:/a:novell:opensuse:slurm-debugsource, p-cpe:/a:novell:opensuse:slurm-devel, p-cpe:/a:novell:opensuse:slurm-hdf5, p-cpe:/a:novell:opensuse:slurm-hdf5-debuginfo, p-cpe:/a:novell:opensuse:slurm-lua, p-cpe:/a:novell:opensuse:slurm-lua-debuginfo, p-cpe:/a:novell:opensuse:slurm-munge, p-cpe:/a:novell:opensuse:slurm-munge-debuginfo, p-cpe:/a:novell:opensuse:slurm-node, p-cpe:/a:novell:opensuse:slurm-node-debuginfo, p-cpe:/a:novell:opensuse:slurm-openlava, p-cpe:/a:novell:opensuse:slurm-pam_slurm, p-cpe:/a:novell:opensuse:slurm-pam_slurm-debuginfo, p-cpe:/a:novell:opensuse:slurm-plugins, p-cpe:/a:novell:opensuse:slurm-plugins-debuginfo, p-cpe:/a:novell:opensuse:slurm-seff, p-cpe:/a:novell:opensuse:slurm-sjstat, p-cpe:/a:novell:opensuse:slurm-slurmdbd, p-cpe:/a:novell:opensuse:slurm-slurmdbd-debuginfo, p-cpe:/a:novell:opensuse:slurm-sql, p-cpe:/a:novell:opensuse:slurm-sql-debuginfo, p-cpe:/a:novell:opensuse:slurm-sview, p-cpe:/a:novell:opensuse:slurm-sview-debuginfo, p-cpe:/a:novell:opensuse:slurm-torque, p-cpe:/a:novell:opensuse:slurm-torque-debuginfo, p-cpe:/a:novell:opensuse:slurm-webdoc, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/19/2020

Vulnerability Publication Date: 11/27/2020

Reference Information

CVE: CVE-2020-27745, CVE-2020-27746