openSUSE Security Update : nodejs14 (openSUSE-2021-66)

high Nessus Plugin ID 145286

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for nodejs14 fixes the following issues :

- New upstream LTS version 14.15.4 :

- CVE-2020-8265: use-after-free in TLSWrap (High) bug in TLS implementation. When writing to a TLS enabled socket, node::StreamBase::Write calls node::TLSWrap::DoWrite with a freshly allocated WriteWrap object as first argument. If the DoWrite method does not return an error, this object is passed back to the caller as part of a StreamWriteResult structure. This may be exploited to corrupt memory leading to a Denial of Service or potentially other exploits (bsc#1180553)

- CVE-2020-8287: HTTP Request Smuggling allow two copies of a header field in a http request. For example, two Transfer-Encoding header fields. In this case Node.js identifies the first header field and ignores the second. This can lead to HTTP Request Smuggling (https://cwe.mitre.org/data/definitions/444.html).
(bsc#1180554)

- New upstream LTS version 14.15.3 :

- deps :

+ upgrade npm to 6.14.9

+ update acorn to v8.0.4

- http2: check write not scheduled in scope destructor

- stream: fix regression on duplex end

- New upstream LTS version 14.15.1 :

- deps: Denial of Service through DNS request (High). A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service by getting the application to resolve a DNS record with a larger number of responses (bsc#1178882, CVE-2020-8277)

This update was imported from the SUSE:SLE-15-SP2:Update update project.

Solution

Update the affected nodejs14 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1178882

https://bugzilla.opensuse.org/show_bug.cgi?id=1180553

https://bugzilla.opensuse.org/show_bug.cgi?id=1180554

https://cwe.mitre.org/data/definitions/444.html

Plugin Details

Severity: High

ID: 145286

File Name: openSUSE-2021-66.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/25/2021

Updated: 3/16/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs14, p-cpe:/a:novell:opensuse:nodejs14-debuginfo, p-cpe:/a:novell:opensuse:nodejs14-debugsource, p-cpe:/a:novell:opensuse:nodejs14-devel, p-cpe:/a:novell:opensuse:npm14, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 1/15/2021

Vulnerability Publication Date: 11/19/2020

Reference Information

CVE: CVE-2020-8265, CVE-2020-8277, CVE-2020-8287