Amazon Linux AMI : postgresql95, postgresql96 (ALAS-2021-1476)

high Nessus Plugin ID 144988
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

The version of postgresql95 installed on the remote host is prior to 9.5.24-1.82. The version of postgresql96 installed on the remote host is prior to 9.6.20-1.84. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS-2021-1476 advisory.

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in- the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
(CVE-2020-25694)

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-25695)

- A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-25696)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update postgresql95' to update your system.
Run 'yum update postgresql96' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2021-1476.html

https://access.redhat.com/security/cve/CVE-2020-25694

https://access.redhat.com/security/cve/CVE-2020-25695

https://access.redhat.com/security/cve/CVE-2020-25696

Plugin Details

Severity: High

ID: 144988

File Name: ala_ALAS-2021-1476.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/14/2021

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2020-25696

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql95, p-cpe:/a:amazon:linux:postgresql95-contrib, p-cpe:/a:amazon:linux:postgresql95-debuginfo, p-cpe:/a:amazon:linux:postgresql95-devel, p-cpe:/a:amazon:linux:postgresql95-docs, p-cpe:/a:amazon:linux:postgresql95-libs, p-cpe:/a:amazon:linux:postgresql95-plperl, p-cpe:/a:amazon:linux:postgresql95-plpython26, p-cpe:/a:amazon:linux:postgresql95-plpython27, p-cpe:/a:amazon:linux:postgresql95-server, p-cpe:/a:amazon:linux:postgresql95-static, p-cpe:/a:amazon:linux:postgresql95-test, p-cpe:/a:amazon:linux:postgresql96, p-cpe:/a:amazon:linux:postgresql96-contrib, p-cpe:/a:amazon:linux:postgresql96-debuginfo, p-cpe:/a:amazon:linux:postgresql96-devel, p-cpe:/a:amazon:linux:postgresql96-docs, p-cpe:/a:amazon:linux:postgresql96-libs, p-cpe:/a:amazon:linux:postgresql96-plperl, p-cpe:/a:amazon:linux:postgresql96-plpython26, p-cpe:/a:amazon:linux:postgresql96-plpython27, p-cpe:/a:amazon:linux:postgresql96-server, p-cpe:/a:amazon:linux:postgresql96-static, p-cpe:/a:amazon:linux:postgresql96-test, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 1/12/2021

Vulnerability Publication Date: 11/12/2020

Reference Information

CVE: CVE-2020-25694, CVE-2020-25695, CVE-2020-25696

ALAS: 2021-1476