SUSE SLES15 Security Update : dovecot23 (SUSE-SU-2021:0028-1)

Medium Nessus Plugin ID 144759

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.2

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for dovecot23 fixes the following issues :

Security issues fixed :

CVE-2020-12100: Fixed a resource exhaustion caused by deeply nested MIME parts (bsc#1174920).

CVE-2020-12673: Fixed an improper implementation of NTLM that did not check the message buffer size (bsc#1174922).

CVE-2020-12674: Fixed an improper implementation of the RPA mechanism (bsc#1174923).

CVE-2020-24386: Fixed an issue with IMAP hibernation that allowed users to access other users' emails (bsc#1180405).

CVE-2020-25275: Fixed a crash when the 10000th MIME part was message/rfc822 (bsc#1180406).

Non-security issues fixed :

Pigeonhole was updated to version 0.5.11.

Dovecot was updated to version 2.3.11.3.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Server Applications 15-SP2 :

zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP2-2021-28=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1174920

https://bugzilla.suse.com/show_bug.cgi?id=1174922

https://bugzilla.suse.com/show_bug.cgi?id=1174923

https://bugzilla.suse.com/show_bug.cgi?id=1180405

https://bugzilla.suse.com/show_bug.cgi?id=1180406

https://www.suse.com/security/cve/CVE-2020-12100/

https://www.suse.com/security/cve/CVE-2020-12673/

https://www.suse.com/security/cve/CVE-2020-12674/

https://www.suse.com/security/cve/CVE-2020-24386/

https://www.suse.com/security/cve/CVE-2020-25275/

http://www.nessus.org/u?49a0b289

Plugin Details

Severity: Medium

ID: 144759

File Name: suse_SU-2021-0028-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2021/01/06

Updated: 2021/01/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.2

CVSS Score Source: CVE-2020-24386

CVSS v2.0

Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:dovecot23, p-cpe:/a:novell:suse_linux:dovecot23-backend-mysql, p-cpe:/a:novell:suse_linux:dovecot23-backend-mysql-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-backend-pgsql, p-cpe:/a:novell:suse_linux:dovecot23-backend-pgsql-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-backend-sqlite, p-cpe:/a:novell:suse_linux:dovecot23-backend-sqlite-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-debugsource, p-cpe:/a:novell:suse_linux:dovecot23-devel, p-cpe:/a:novell:suse_linux:dovecot23-fts, p-cpe:/a:novell:suse_linux:dovecot23-fts-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-fts-lucene, p-cpe:/a:novell:suse_linux:dovecot23-fts-lucene-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-fts-solr, p-cpe:/a:novell:suse_linux:dovecot23-fts-solr-debuginfo, p-cpe:/a:novell:suse_linux:dovecot23-fts-squat, p-cpe:/a:novell:suse_linux:dovecot23-fts-squat-debuginfo, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2021/01/05

Vulnerability Publication Date: 2020/08/12

Reference Information

CVE: CVE-2020-12100, CVE-2020-12673, CVE-2020-12674, CVE-2020-24386, CVE-2020-25275