SUSE SLED15 / SLES15 Security Update : python3 (SUSE-SU-2020:3930-1)

high Nessus Plugin ID 144586
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for python3 fixes the following issues :

Fixed CVE-2020-27619 (bsc#1178009), where Lib/test/multibytecodec_support calls eval() on content retrieved via HTTP.

Change setuptools and pip version numbers according to new wheels

Handful of changes to make python36 compatible with SLE15 and SLE12 (jsc#ECO-2799, jsc#SLE-13738)

add triplets for mips-r6 and riscv

RISC-V needs CTYPES_PASS_BY_REF_HACK

Update to 3.6.12 (bsc#1179193)

Ensure python3.dll is loaded from correct locations when Python is embedded

The __hash__() methods of ipaddress.IPv4Interface and ipaddress.IPv6Interface incorrectly generated constant hash values of 32 and 128 respectively. This resulted in always causing hash collisions. The fix uses hash() to generate hash values for the tuple of (address, mask length, network address).

Prevent http header injection by rejecting control characters in http.client.putrequest(…).

Unpickling invalid NEWOBJ_EX opcode with the C implementation raises now UnpicklingError instead of crashing.

Avoid infinite loop when reading specially crafted TAR files using the tarfile module

This release also fixes CVE-2020-26116 (bsc#1177211) and CVE-2019-20907 (bsc#1174091).

Update to 3.6.11 :

Disallow CR or LF in email.headerregistry. Address arguments to guard against header injection attacks.

Disallow control characters in hostnames in http.client, addressing CVE-2019-18348. Such potentially malicious header injection URLs now cause a InvalidURL to be raised. (bsc#1155094)

CVE-2020-8492: The AbstractBasicAuthHandler class of the urllib.request module uses an inefficient regular expression which can be exploited by an attacker to cause a denial of service. Fix the regex to prevent the catastrophic backtracking. Vulnerability reported by Ben Caller and Matt Schwager.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server for SAP 15 :

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-3930=1

SUSE Linux Enterprise Server 15-LTSS :

zypper in -t patch SUSE-SLE-Product-SLES-15-2020-3930=1

SUSE Linux Enterprise Module for Development Tools 15-SP3 :

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2020-3930=1

SUSE Linux Enterprise Module for Development Tools 15-SP2 :

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP2-2020-3930=1

SUSE Linux Enterprise Module for Development Tools 15-SP1 :

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-3930=1

SUSE Linux Enterprise Module for Basesystem 15-SP3 :

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2020-3930=1

SUSE Linux Enterprise Module for Basesystem 15-SP2 :

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2020-3930=1

SUSE Linux Enterprise Module for Basesystem 15-SP1 :

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-3930=1

SUSE Linux Enterprise High Performance Computing 15-LTSS :

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3930=1

SUSE Linux Enterprise High Performance Computing 15-ESPOS :

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3930=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1155094

https://bugzilla.suse.com/show_bug.cgi?id=1174091

https://bugzilla.suse.com/show_bug.cgi?id=1174571

https://bugzilla.suse.com/show_bug.cgi?id=1174701

https://bugzilla.suse.com/show_bug.cgi?id=1177211

https://bugzilla.suse.com/show_bug.cgi?id=1178009

https://bugzilla.suse.com/show_bug.cgi?id=1179193

https://bugzilla.suse.com/show_bug.cgi?id=1179630

https://www.suse.com/security/cve/CVE-2019-16935/

https://www.suse.com/security/cve/CVE-2019-18348/

https://www.suse.com/security/cve/CVE-2019-20907/

https://www.suse.com/security/cve/CVE-2019-5010/

https://www.suse.com/security/cve/CVE-2020-14422/

https://www.suse.com/security/cve/CVE-2020-26116/

https://www.suse.com/security/cve/CVE-2020-27619/

https://www.suse.com/security/cve/CVE-2020-8492/

http://www.nessus.org/u?825c06e1

Plugin Details

Severity: High

ID: 144586

File Name: suse_SU-2020-3930-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 12/24/2020

Updated: 1/13/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libpython3_6m1_0, p-cpe:/a:novell:suse_linux:libpython3_6m1_0-debuginfo, p-cpe:/a:novell:suse_linux:python3, p-cpe:/a:novell:suse_linux:python3-base, p-cpe:/a:novell:suse_linux:python3-curses, p-cpe:/a:novell:suse_linux:python3-curses-debuginfo, p-cpe:/a:novell:suse_linux:python3-dbm, p-cpe:/a:novell:suse_linux:python3-dbm-debuginfo, p-cpe:/a:novell:suse_linux:python3-debuginfo, p-cpe:/a:novell:suse_linux:python3-debugsource, p-cpe:/a:novell:suse_linux:python3-devel, p-cpe:/a:novell:suse_linux:python3-devel-debuginfo, p-cpe:/a:novell:suse_linux:python3-idle, p-cpe:/a:novell:suse_linux:python3-testsuite, p-cpe:/a:novell:suse_linux:python3-tk, p-cpe:/a:novell:suse_linux:python3-tk-debuginfo, p-cpe:/a:novell:suse_linux:python3-tools, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 12/23/2020

Vulnerability Publication Date: 9/28/2019

Reference Information

CVE: CVE-2019-16935, CVE-2019-18348, CVE-2019-20907, CVE-2019-5010, CVE-2020-14422, CVE-2020-26116, CVE-2020-27619, CVE-2020-8492