Apache Struts 2.x < 2.5.26 RCE (S2-061) (direct check)

critical Nessus Plugin ID 144365
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


Apache Struts installed on the remote host is affected by a remote code execution vulnerability.


The version of Apache Struts installed on the remote host is 2.x prior to 2.5.26. It is, therefore, affected by a a remote code execution vulnerability in its OGNL evaluation functionality due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this to execute arbitrary commands on an affected host.


Upgrade to Apache Struts version 2.5.26 or later. Alternatively, apply the workarounds as referenced in the vendor security bulletins.

See Also



Plugin Details

Severity: Critical

ID: 144365

File Name: struts_cve_2020_17530.nbin

Version: 1.11

Type: remote

Family: CGI abuses

Published: 12/17/2020

Updated: 7/12/2021

Dependencies: http_version.nasl

Risk Information

CVSS Score Source: CVE-2020-17530


Risk Factor: Critical

Score: 9.2


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/6/2020

Vulnerability Publication Date: 12/8/2020

Exploitable With

Metasploit (Apache Struts 2 Forced Multi OGNL Evaluation)

Reference Information

CVE: CVE-2020-17530

IAVA: 2020-A-0565