CVE-2020-17530

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Forced OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution. Affected software : Apache Struts 2.0.0 - Struts 2.5.25.

References

https://cwiki.apache.org/confluence/display/WW/S2-061

http://jvn.jp/en/jp/JVN43969166/index.html

http://packetstormsecurity.com/files/160721/Apache-Struts-2-Forced-Multi-OGNL-Evaluation.html

https://security.netapp.com/advisory/ntap-20210115-0005/

https://www.oracle.com/security-alerts/cpujan2021.html

https://www.oracle.com/security-alerts/cpuApr2021.html

Details

Source: MITRE

Published: 2020-12-11

Updated: 2021-07-21

Type: CWE-94

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
151425Apache Struts 2.0.0 < 2.5.26 Possible Remote Code Execution vulnerability (S2-061)NessusMisc.
critical
112765Apache Struts 2.x < 2.5.26 Remote Code Execution (S2-061)Web Application ScanningComponent Vulnerability
critical
148986Oracle MySQL Enterprise Monitor Multiple Vulnerabilities (Apr 2021 CPU)NessusCGI abuses
critical
144365Apache Struts 2.x < 2.5.26 RCE (S2-061) (direct check)NessusCGI abuses
critical
143599Apache Struts 2.x < 2.5.26 RCE (S2-061)NessusMisc.
critical