openSUSE Security Update : xen (openSUSE-2020-2192)

high Nessus Plugin ID 143538

Language:

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for xen fixes the following issues :

- bsc#1178963 - VUL-0: xen: stack corruption from XSA-346 change (XSA-355)

This update was imported from the SUSE:SLE-15-SP1:Update update project.

Solution

Update the affected xen packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1177409

https://bugzilla.opensuse.org/show_bug.cgi?id=1177412

https://bugzilla.opensuse.org/show_bug.cgi?id=1177413

https://bugzilla.opensuse.org/show_bug.cgi?id=1177414

https://bugzilla.opensuse.org/show_bug.cgi?id=1178591

https://bugzilla.opensuse.org/show_bug.cgi?id=1178963

Plugin Details

Severity: High

ID: 143538

File Name: openSUSE-2020-2192.nasl

Version: 1.3

Type: local

Agent: unix

Published: 12/8/2020

Updated: 5/12/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-27672

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xen, p-cpe:/a:novell:opensuse:xen-debugsource, p-cpe:/a:novell:opensuse:xen-devel, p-cpe:/a:novell:opensuse:xen-doc-html, p-cpe:/a:novell:opensuse:xen-libs, p-cpe:/a:novell:opensuse:xen-libs-32bit, p-cpe:/a:novell:opensuse:xen-libs-32bit-debuginfo, p-cpe:/a:novell:opensuse:xen-libs-debuginfo, p-cpe:/a:novell:opensuse:xen-tools, p-cpe:/a:novell:opensuse:xen-tools-debuginfo, p-cpe:/a:novell:opensuse:xen-tools-domU, p-cpe:/a:novell:opensuse:xen-tools-domU-debuginfo, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/7/2020

Vulnerability Publication Date: 10/22/2020

Reference Information

CVE: CVE-2020-27670, CVE-2020-27671, CVE-2020-27672, CVE-2020-27674, CVE-2020-28368