OpenWrt < 18.06.2 XSS (direct check)

medium Nessus Plugin ID 143480

Synopsis

The web application running on the remote web server is affected by a cross-site scripting vulnerability.

Description

A cross-site scripting (XSS) vulnerability exists in OpenWrt web user-interface due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to OpenWrt version 18.06.2 or later

See Also

https://bugs.openwrt.org/index.php?do=details&task_id=1974

Plugin Details

Severity: Medium

ID: 143480

File Name: openwrt_cve_2018_19630.nbin

Version: 1.21

Type: remote

Published: 12/4/2020

Updated: 8/15/2022

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-19630

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:openwrt:openwrt

Required KB Items: Host/OS/OpenWrt

Exploit Ease: No known exploits are available

Patch Publication Date: 11/28/2018

Vulnerability Publication Date: 11/28/2018

Reference Information

CVE: CVE-2018-19630