Ubuntu 18.04 LTS / 20.04 LTS / 20.10 : WebKitGTK vulnerabilities (USN-4648-1)

High Nessus Plugin ID 143269

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.4

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 20.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4648-1 advisory.

- A type confusion issue was addressed with improved memory handling. This issue is fixed in Safari 14.0.
Processing maliciously crafted web content may lead to arbitrary code execution. (CVE-2020-9948)

- A use after free issue was addressed with improved memory management. This issue is fixed in Safari 14.0.
Processing maliciously crafted web content may lead to arbitrary code execution. (CVE-2020-9951)

- An input validation issue was addressed with improved input validation. This issue is fixed in iOS 14.0 and iPadOS 14.0, tvOS 14.0, watchOS 7.0, Safari 14.0, iCloud for Windows 11.4, iCloud for Windows 7.21.
Processing maliciously crafted web content may lead to a cross site scripting attack. (CVE-2020-9952)

- An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in Safari 14.0. Processing maliciously crafted web content may lead to code execution. (CVE-2020-9983)

- The bubblewrap sandbox of WebKitGTK and WPE WebKit, prior to 2.28.3, failed to properly block access to CLONE_NEWUSER and the TIOCSTI ioctl. CLONE_NEWUSER could potentially be used to confuse xdg-desktop- portal, which allows access outside the sandbox. TIOCSTI can be used to directly execute commands outside the sandbox by writing to the controlling terminal's input buffer, similar to CVE-2017-5226.
(CVE-2020-13753)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4648-1

Plugin Details

Severity: High

ID: 143269

File Name: ubuntu_USN-4648-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/11/26

Updated: 2020/12/01

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 7.4

CVSS Score Source: CVE-2020-13753

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, p-cpe:/a:canonical:ubuntu_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:canonical:ubuntu_linux:gir1.2-webkit2-4.0, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-37, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-37-gtk2, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:canonical:ubuntu_linux:webkit2gtk-driver

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/11/26

Vulnerability Publication Date: 2020/07/14

Reference Information

CVE: CVE-2020-9948, CVE-2020-9951, CVE-2020-9952, CVE-2020-9983, CVE-2020-13753

USN: 4648-1