Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : PostgreSQL vulnerabilities (USN-4633-1)

Medium Nessus Plugin ID 142968

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 8.4

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4633-1 advisory.

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in- the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
(CVE-2020-25694)

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-25695)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4633-1

Plugin Details

Severity: Medium

ID: 142968

File Name: ubuntu_USN-4633-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/11/17

Updated: 2020/12/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 8.4

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, p-cpe:/a:canonical:ubuntu_linux:libecpg-compat3, p-cpe:/a:canonical:ubuntu_linux:libecpg-dev, p-cpe:/a:canonical:ubuntu_linux:libecpg6, p-cpe:/a:canonical:ubuntu_linux:libpgtypes3, p-cpe:/a:canonical:ubuntu_linux:libpq-dev, p-cpe:/a:canonical:ubuntu_linux:libpq5, p-cpe:/a:canonical:ubuntu_linux:postgresql-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-client-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-contrib-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-plperl-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-plpython3-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-pltcl-9.5, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-10, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-12, p-cpe:/a:canonical:ubuntu_linux:postgresql-server-dev-9.5

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2020/11/17

Vulnerability Publication Date: 2020/11/12

Reference Information

CVE: CVE-2020-25694, CVE-2020-25695, CVE-2020-25696

USN: 4633-1

IAVB: 2020-B-0069