Pulse Policy Secure < 9.1R9 (SA44601)

high Nessus Plugin ID 142057

Synopsis

The remote device is affected by multiple vulnerabilities.

Description

According to its self-reported version, the version of Pulse Policy Secure running on the remote host is prior to 9.1R9. It is, therefore, affected by the following vulnerabilities:

- A vulnerability in the Pulse Connect Secure < 9.1R9 admin web interface could allow an authenticated attacker to perform an arbitrary code execution using uncontrolled gzip extraction. (CVE-2020-8260)

- A vulnerability in the Pulse Connect Secure / Pulse Policy Secure < 9.1R9 is vulnerable to arbitrary cookie injection. (CVE-2020-8261)

- jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable
__proto__ property, it could extend the native Object.prototype. (CVE-2019-11358)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Pulse Policy Secure version 9.1R9 or later.

See Also

https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44601

Plugin Details

Severity: High

ID: 142057

File Name: pulse_policy_secure-sa44601.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 10/30/2020

Updated: 1/21/2022

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2020-8260

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pulsesecure:pulse_policy_secure

Required KB Items: installed_sw/Pulse Policy Secure

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/26/2020

Vulnerability Publication Date: 1/18/2018

CISA Known Exploited Dates: 4/23/2021

Exploitable With

Metasploit (Pulse Secure VPN gzip RCE)

Reference Information

CVE: CVE-2015-9251, CVE-2019-11358, CVE-2020-8255, CVE-2020-8260, CVE-2020-8261, CVE-2020-8262, CVE-2020-8263, CVE-2020-15352

IAVA: 2020-A-0495