Ubuntu 18.04 LTS / 20.04 LTS : Linux kernel vulnerabilities (USN-4576-1)

high Nessus Plugin ID 141451
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4576-1 advisory.

- A memory out-of-bounds read flaw was found in the Linux kernel before 5.9-rc2 with the ext3/ext4 file system, in the way it accesses a directory with broken indexing. This flaw allows a local user to crash the system if the directory exists. The highest threat from this vulnerability is to system availability.
(CVE-2020-14314)

- A flaw was found in the Linux kernel before 5.9-rc4. A failure of the file system metadata validator in XFS can cause an inode with a valid, user-creatable extended attribute to be flagged as corrupt. This can lead to the filesystem being shutdown, or otherwise rendered inaccessible until it is remounted, leading to a denial of service. The highest threat from this vulnerability is to system availability.
(CVE-2020-14385)

- A race condition between hugetlb sysctl handlers in mm/hugetlb.c in the Linux kernel before 5.8.8 could be used by local attackers to corrupt memory, cause a NULL pointer dereference, or possibly have unspecified other impact, aka CID-17743798d812. (CVE-2020-25285)

- A flaw was found in the Linux kernel's implementation of biovecs in versions before 5.9-rc7. A zero-length biovec request issued by the block subsystem could cause the kernel to enter an infinite loop, causing a denial of service. This flaw allows a local attacker with basic privileges to issue requests to a block device, resulting in a denial of service. The highest threat from this vulnerability is to system availability. (CVE-2020-25641)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4576-1

Plugin Details

Severity: High

ID: 141451

File Name: ubuntu_USN-4576-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 10/14/2020

Updated: 1/26/2021

Dependencies: ssh_get_info.nasl, linux_alt_patch_detect.nasl

Risk Information

CVSS Score Source: CVE-2020-16119

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1021-raspi, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1026-kvm, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1028-aws, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1028-gcp, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1028-oracle, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-1031-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-51-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-51-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-5.4.0-51-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-aws, p-cpe:/a:canonical:ubuntu_linux:linux-image-aws-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-azure-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-gcp, p-cpe:/a:canonical:ubuntu_linux:linux-image-gcp-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-gke, p-cpe:/a:canonical:ubuntu_linux:linux-image-kvm, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-20.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem, p-cpe:/a:canonical:ubuntu_linux:linux-image-oem-osp1, p-cpe:/a:canonical:ubuntu_linux:linux-image-oracle, p-cpe:/a:canonical:ubuntu_linux:linux-image-oracle-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi2, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi2-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-raspi2-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-snapdragon-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-snapdragon-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-18.04-edge, p-cpe:/a:canonical:ubuntu_linux:linux-image-virtual-hwe-20.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/14/2020

Vulnerability Publication Date: 9/13/2020

Reference Information

CVE: CVE-2020-14314, CVE-2020-14385, CVE-2020-16119, CVE-2020-16120, CVE-2020-25285, CVE-2020-25641

USN: 4576-1