Fortinet FortiOS < 6.0.10 / 6.2.x < 6.2.4 / 6.4.x < 6.4.1 Improper Authentication (FG-IR-19-283)

critical Nessus Plugin ID 141122
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by an improper authentication vulnerability.

Description

The remote host is running a version of FortiOS prior to 6.0.10, 6.2.x prior to 6.2.4, or 6.4.x prior to 6.4.1. It is, therefore, affected by an improper authentication vulnerability due to an issue with the 'username-case-sensitivity' CLI attribute for the SSL VPN. An unauthenticated, remote attacker can exploit this, by changing the case of the username, to log in without being prompted for FortiToken 2FA.

Solution

Upgrade to Fortinet FortiOS version to 6.0.10, 6.2.4, 6.4.1 or later, or apply the workaround from the advisory.

See Also

https://www.fortiguard.com/psirt/FG-IR-19-283

Plugin Details

Severity: Critical

ID: 141122

File Name: fortios_FG-IR-19-283.nasl

Version: 1.14

Type: local

Family: Firewalls

Published: 10/2/2020

Updated: 8/12/2021

Dependencies: fortinet_version.nbin

Risk Information

CVSS Score Source: CVE-2020-12812

VPR

Risk Factor: Critical

Score: 9.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/version, Host/Fortigate/model

Exploit Ease: No known exploits are available

Patch Publication Date: 7/24/2020

Vulnerability Publication Date: 7/24/2020

Reference Information

CVE: CVE-2020-12812

IAVA: 2020-A-0440-S