Cisco Data Center Network Manager Privilege Escalation (cisco-sa-20180905-cdcnm-escalation)

High Nessus Plugin ID 140653

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote device is missing a vendor-supplied security patch

Description

According to its self-reported version, Cisco Data Center Network Manager is prior to version 11.0(1) and is, therefore, affected by a privilege escalation vulnerability in the web-based management interface due to incomplete validation of user input. An authenticated attacker could exploit this vulnerability by sending a crafted HTTP request to the target application in order to issue commands on the underlying operating system as the root user.

Please see the included Cisco BID and Cisco Security Advisory for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID CSCvi47733

See Also

http://www.nessus.org/u?db8f041c

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvi47733

Plugin Details

Severity: High

ID: 140653

File Name: cisco-sa-20180905-cdcnm-escalation.nasl

Version: 1.2

Type: combined

Family: CISCO

Published: 2020/09/18

Updated: 2020/09/21

Dependencies: 67246, 67244, 67245

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2018-0440

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:data_center_network_manager

Required KB Items: installed_sw/Cisco Prime DCNM, installed_sw/cisco_dcnm_web

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/09/05

Vulnerability Publication Date: 2018/09/05

Reference Information

CVE: CVE-2018-0440