openSUSE Security Update : ark (openSUSE-2020-1310)

low Nessus Plugin ID 140172

Language:

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for ark fixes the following issues :

- CVE-2020-24654: maliciously crafted TAR archive can install files outside the extraction directory (boo#1175857)	

Solution

Update the affected ark packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1175857

Plugin Details

Severity: Low

ID: 140172

File Name: openSUSE-2020-1310.nasl

Version: 1.4

Type: local

Agent: unix

Published: 9/2/2020

Updated: 9/23/2020

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-24654

CVSS v3

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ark, p-cpe:/a:novell:opensuse:ark-debuginfo, p-cpe:/a:novell:opensuse:ark-debugsource, p-cpe:/a:novell:opensuse:ark-lang, p-cpe:/a:novell:opensuse:libkerfuffle18, p-cpe:/a:novell:opensuse:libkerfuffle18-debuginfo, p-cpe:/a:novell:opensuse:libkerfuffle20, p-cpe:/a:novell:opensuse:libkerfuffle20-debuginfo, cpe:/o:novell:opensuse:15.1, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 9/1/2020

Vulnerability Publication Date: 9/2/2020

Reference Information

CVE: CVE-2020-24654