Microsoft Edge (Chromium) < 84.0.522.40 Multiple Vulnerabilities

High Nessus Plugin ID 139034

Synopsis

The remote host has an web browser installed that is affected by multiple vulnerabilities.

Description

The version of Microsoft Edge (Chromium) installed on the remote Windows host is prior to 84.0.522.40. It is, therefore, affected by multiple vulnerabilities :

- Heap-based buffer overflow in PDFium allowed a remote attacker to potentially exploit heap corruption via a crafted PDF file. (CVE-2020-6513)

- Use after free in tab strip allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (CVE-2020-6515)

- Out of bounds write in Skia allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (CVE-2020-6523)

In addition, Microsoft Edge (Chromium) is also affected by several additional vulnerabilities including additional use-after-free vulnerabilities, multiple heap-based buffer overflow conditions, privilege escalation, type confusion, and insufficient policy enforcements.

Solution

Upgrade to Microsoft Edge (Chromium) 84.0.522.40 or later.

See Also

http://www.nessus.org/u?b4f0f972

http://www.nessus.org/u?2ec7f076

Plugin Details

Severity: High

ID: 139034

File Name: microsoft_edge_chromium_84_0_522_40.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 2020/07/28

Updated: 2020/08/14

Dependencies: 136969

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2020-6512

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:edge

Required KB Items: installed_sw/Microsoft Edge (Chromium), SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/07/16

Vulnerability Publication Date: 2020/07/16

Reference Information

CVE: CVE-2020-1341, CVE-2020-6510, CVE-2020-6511, CVE-2020-6512, CVE-2020-6513, CVE-2020-6514, CVE-2020-6515, CVE-2020-6516, CVE-2020-6517, CVE-2020-6518, CVE-2020-6519, CVE-2020-6520, CVE-2020-6522, CVE-2020-6523, CVE-2020-6524, CVE-2020-6525, CVE-2020-6526, CVE-2020-6527, CVE-2020-6528, CVE-2020-6529, CVE-2020-6530, CVE-2020-6531, CVE-2020-6533, CVE-2020-6534, CVE-2020-6535, CVE-2020-6536

IAVA: 2020-A-0302-S