openSUSE Security Update : tomcat (openSUSE-2020-1063)

Medium Nessus Plugin ID 138987

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for tomcat fixes the following issues: 	 Tomcat was updated to 9.0.36 See changelog at

- CVE-2020-11996: Fixed an issue which by sending a specially crafted sequence of HTTP/2 requests could have triggered high CPU usage for several seconds making potentially the server unresponsive (bsc#1173389).

This update was imported from the SUSE:SLE-15-SP2:Update update project.

Solution

Update the affected tomcat packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1173389

Plugin Details

Severity: Medium

ID: 138987

File Name: openSUSE-2020-1063.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/07/27

Updated: 2020/07/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tomcat, p-cpe:/a:novell:opensuse:tomcat-admin-webapps, p-cpe:/a:novell:opensuse:tomcat-docs-webapp, p-cpe:/a:novell:opensuse:tomcat-el-3_0-api, p-cpe:/a:novell:opensuse:tomcat-embed, p-cpe:/a:novell:opensuse:tomcat-javadoc, p-cpe:/a:novell:opensuse:tomcat-jsp-2_3-api, p-cpe:/a:novell:opensuse:tomcat-jsvc, p-cpe:/a:novell:opensuse:tomcat-lib, p-cpe:/a:novell:opensuse:tomcat-servlet-4_0-api, p-cpe:/a:novell:opensuse:tomcat-webapps, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/07/26

Vulnerability Publication Date: 2020/06/26

Reference Information

CVE: CVE-2020-11996