IBM DB2 9.7 < FP11 40162 / 10.1 < FP6 40161 / 10.5 < FP11 40160 / 11.1 < FP5 40159 / 11.5 < Mod 4 FP0 Multiple Vulnerabilities (UNIX)

High Nessus Plugin ID 138332

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

According to its version, the installation of IBM DB2 running on the remote host is either 9.7 prior to Fix Pack 11 Special Build 40162, 10.1 prior to Fix Pack 6 Special Build 40161, 10.5 prior to Fix Pack 11 Special Build 40160, or 11.1 prior to Fix Pack 5 Special Build 40159, 11.5 prior to Mod 4 Fix Pack 0. It is, therefore, affected by one or more of the following vulnerabilities:

- IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 is vulnerable to a denial of service, caused by improper handling of Secure Sockets Layer (SSL) renegotiation requests. By sending specially-crafted requests, a remote attacker could exploit this vulnerability to increase the resource usage on the system. (CVE-2020-4355)

- IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 is vulnerable to a buffer overflow, caused by improper bounds checking which allows a local attacker to execute arbitrary code on the system with root privileges. (CVE-2020-4363)

- IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 allows a local user to obtain sensitive information using a race condition of a symbolic link. (CVE-2020-4386, CVE-2020-4387)

- IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 allows a local attacker to perform unauthorized actions on the system, caused by improper usage of shared memory.
By sending a specially-crafted request, an attacker can exploit this vulnerability to obtain sensitive information or cause a denial of service (DoS). (CVE-2020-4414)

- IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 could allow an unauthenticated attacker to cause a denial of service due a hang in the execution of a terminate command. (CVE-2020-4420) Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Apply the appropriate IBM DB2 Fix Pack or Special Build based on the most recent fix pack level for your branch.

See Also

https://www.ibm.com/support/pages/node/6242342

https://www.ibm.com/support/pages/node/6242332

https://www.ibm.com/support/pages/node/6242336

https://www.ibm.com/support/pages/node/6242350

https://www.ibm.com/support/pages/node/6242356

https://www.ibm.com/support/pages/node/6242362

Plugin Details

Severity: High

ID: 138332

File Name: db2_1154_nix.nasl

Version: 1.7

Type: local

Agent: unix

Family: Databases

Published: 2020/07/09

Updated: 2020/12/04

Dependencies: 86653

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS Score Source: CVE-2020-4363

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:db2

Required KB Items: installed_sw/DB2 Server

Excluded KB Items: SMB/db2/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/06/30

Vulnerability Publication Date: 2020/06/30

Reference Information

CVE: CVE-2020-4355, CVE-2020-4363, CVE-2020-4386, CVE-2020-4387, CVE-2020-4414, CVE-2020-4420

IAVB: 2020-B-0035-S, 2020-B-0043-S