SuSE-SA:2004:016: squid

Critical Nessus Plugin ID 13832


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SuSE-SA:2004:016 (squid).

Squid is a feature-rich web-proxy with support for various web-related protocols.
The NTLM authentication helper application of Squid is vulnerable to a buffer overflow that can be exploited remotely by using a long password to execute arbitrary code.
NTLM authentication is enabled by default in the Squid package that is shipped by SUSE LINUX.

There is no workaround known other then turning off the NTLM authentication.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: Critical

ID: 13832

File Name: suse_SA_2004_016.nasl

Version: $Revision: 1.12 $

Agent: unix

Published: 2004/07/25

Modified: 2010/10/06

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With

Metasploit (Squid NTLM Authenticate Overflow)

Reference Information

CVE: CVE-2004-0541

BID: 10500