SuSE-SA:2004:013: cvs

High Nessus Plugin ID 13830


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SuSE-SA:2004:013 (cvs).

The Concurrent Versions System (CVS) offers tools which allow developers to share and maintain large software projects.
Stefan Esser reported buffer overflow conditions within the cvs program.
They allow remote attackers to execute arbitrary code as the user the cvs server runs as. Since there is no easy workaround we strongly recommend to update the cvs package.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: High

ID: 13830

File Name: suse_SA_2004_013.nasl

Version: $Revision: 1.11 $

Agent: unix

Published: 2004/07/25

Modified: 2010/10/15

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With


Reference Information

CVE: CVE-2004-0396