SuSE-SA:2004:004: gaim

Medium Nessus Plugin ID 13822


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SuSE-SA:2004:004 (gaim).

Gaim is a multi-protocol instant-messaging client. Stefan Esser found 12 vulnerabilities in gaim that can lead to a remote system compromise with the privileges of the user running GAIM.
The GAIM package that SUSE LINUX ships is affected by just two of these bug:
- Yahoo Packet Parser Overflow
- HTTP Proxy Connect Overflow

The first vulnerability is easy to exploit and results in a classic stack overflow which can be used to execute arbitrary code.
The latter vulnerability requires the gaim client use a HTTP proxy under the control of the attacker. The exploitation of this bug results in arbitrary code execution too.

There is no known workaround.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, to apply the update use the command 'rpm -Fhv file.rpm'.


Plugin Details

Severity: Medium

ID: 13822

File Name: suse_SA_2004_004.nasl

Version: $Revision: 1.7 $

Agent: unix

Published: 2004/07/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list