SuSE-SA:2003:051: lftp

Medium Nessus Plugin ID 13819


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SuSE-SA:2003:051 (lftp).

The the flexible and powerful FTP command-line client lftp is vulnerable to two remote buffer overflows.
When using lftp via HTTP or HTTPS to execute commands like 'ls' or 'rels' specially prepared directories on the server can trigger a buffer overflow in the HTTP handling functions of lftp to possibly execute arbitrary code on the client-side.
Please note, to exploit these bugs an attacker has to control the server- side of the context and the attacker will only gain access to the account of the user that is executing lftp.

There is no temporary workaround known.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: Medium

ID: 13819

File Name: suse_SA_2003_051.nasl

Version: $Revision: 1.6 $

Agent: unix

Published: 2004/07/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list