SuSE-SA:2003:044: thttpd

High Nessus Plugin ID 13812


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SuSE-SA:2003:044 (thttpd).

Two vulnerabilities were found in the 'tiny' web-server thttpd.
The first bug is a buffer overflow that can be exploited remotely to overwrite the EBP register of the stack. Due to memory-alignment of the stack done by gcc 3.x this bug can not be exploited. All thttpd versions mentioned in this advisory are compiled with gcc 3.x and are therefore not exploitable.
The other bug occurs in the virtual-hosting code of thttpd. A remote attacker can bypass the virtual-hosting mechanism to read arbitrary files.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: High

ID: 13812

File Name: suse_SA_2003_044.nasl

Version: $Revision: 1.13 $

Agent: unix

Published: 2004/07/25

Modified: 2016/12/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: No exploit is required

Reference Information

CVE: CVE-2002-1562, CVE-2003-0899

BID: 8906, 8924

CWE: 119