SUSE-SA:2003:042: mysql

Medium Nessus Plugin ID 13810


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2003:042 (mysql).

A remotely exploitable buffer overflow within the authentication code of MySQL has been reported. This allows remote attackers who have access to the 'User' table to execute arbitrary commands as mysql user.
The list of affected packages is as follows:
mysql, mysql-client, mysql-shared, mysql-bench, mysql-devel, mysql-Max.
In this advisory the MD5 sums for the mysql, mysql-shared and mysql-devel packages are listed.

To be sure the update takes effect you have to restart the MySQL server by executing the following command as root:

/usr/sbin/rcmysql restart

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: Medium

ID: 13810

File Name: suse_SA_2003_042.nasl

Version: $Revision: 1.7 $

Agent: unix

Published: 2004/07/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list