SUSE-SA:2003:041: lsh

Medium Nessus Plugin ID 13809


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2003:041 (lsh).

LSH is the GNU implementation of SSH and can be seen as an alternative to OpenSSH.
Recently various remotely exploitable buffer overflows have been reported in LSH. These allow attackers to execute arbitrary code as root on un-patched systems.
LSH is not installed by default on SUSE LINUX. An update is therefore only recommended if you run LSH.
Maintained SUSE products are not affected by this bug as LSH is not packaged on maintained products such as the Enterprise Server.

For the updates to take effect execute the following command as root:

/usr/sbin/rclshd restart

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: Medium

ID: 13809

File Name: suse_SA_2003_041.nasl

Version: $Revision: 1.7 $

Agent: unix

Published: 2004/07/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list