SUSE-SA:2003:022: apcupsd

Critical Nessus Plugin ID 13792


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2003:022 (apcupsd).

The controlling and management daemon apcupsd for APC's Unbreakable Power Supplies is vulnerable to several buffer overflows and format bugs. These bugs can be exploited remotely by an attacker to gain root access to the machine apcupsd is running on.

There is no temporary fix known.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: Critical

ID: 13792

File Name: suse_SA_2003_022.nasl

Version: $Revision: 1.12 $

Agent: unix

Published: 2004/07/25

Modified: 2010/10/06

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2003-0098, CVE-2003-0099

BID: 7200