SUSE-SA:2003:013: sendmail, sendmail-tls

High Nessus Plugin ID 13784


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2003:013 (sendmail, sendmail-tls).

sendmail is the most widely used mail transport agent (MTA) in the internet. A remotely exploitable buffer overflow has been found in all versions of sendmail that come with SUSE products. These versions include sendmail-8.11 and sendmail-8.12 releases. sendmail is the MTA subsystem that is installed by default on all SUSE products up to and including SUSE LINUX 8.0 and the SUSE LINUX Enterprise Server 7.

The vulnerability is triggered by an email message sent through the sendmail MTA subsystem. In that respect, it is different from commonly known bugs that occur in the context of an open TCP connection. By consequence, the vulnerability also exists if email messages get forwarded over a relay that itself does not run a vulnerable MTA. This specific detail and the wide distribution of sendmail in the internet causes this vulnerability to be considered an error of major severity.

The buffer overflow happens on the heap and is known to be exploitable.
As of the writing of this announcement, there is no exploit known to exist in the public. Since there is no known workaround for this vulnerability other than using a different MTA, it is strongly recommended to install the update packages as offered at the locations as listed below.

We would like to express our gratitude to Eric Allman for notifying SUSE Security of the problem. The vulnerability was discovered by ISS Internet Security Systems, inc.

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: High

ID: 13784

File Name: suse_SA_2003_013.nasl

Version: $Revision: 1.7 $

Agent: unix

Published: 2004/07/25

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list