High Nessus Plugin ID 13774
SynopsisThe remote host is missing a vendor-supplied security patch
DescriptionThe remote host is missing the patch for the advisory SUSE-SA:2003:0009 (mod_php4).
The Apache module mod_php4 supports the widely used Web scripting language PHP.
Under some special circumstances a buffer overflow can be triggered in mod_php4's wordwrap() function. This buffer overflow can be used to overwrite heap memory and possibly can lead to remote system compromise.
Just mod_php4 versions greater than 4.1.2 and less than 4.3.0 are vulnerable. This affects SUSE LINUX 8.1 and all SUSE LINUX Enterprise Server 8 based products.
There is no temporary fix known. Please install the new packages from our FTP servers.
After updating the mod_php4 module has to be reloaded by Apache.
This can be done by restarting the apache webserver using the following command as root:
Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.