SUSE-SA:2002:036: mod_php4

High Nessus Plugin ID 13757


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2002:036 (mod_php4).

PHP is a well known and widely used web programming language.
If a PHP script runs in 'safe mode' several restrictions are applied to it including limits on execution of external programs.

An attacker can pass shell meta-characters or sendmail(8) command line options via the 5th argument (introduced in version 4.0.5) of the mail() function to execute shell commands or control the behavior of sendmail(8).

The CRLF injection vulnerabilities in fopen(), file(), header(), ...
allow an attacker to bypass ACLs or trigger cross-side scripting.

The mod_php4 package is not installed by default.
A temporary fix is not known.

Please note, that the following packages were rebuild too:
- mod_php4-core
- mod_php4-aolserver
- mod_php4-devel
- mod_php4-servlet
- mod_php4-roxen

Please download the update package for your distribution and verify its integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply the update.


Plugin Details

Severity: High

ID: 13757

File Name: suse_SA_2002_036.nasl

Version: $Revision: 1.10 $

Agent: unix

Published: 2004/07/25

Modified: 2016/12/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Reference Information

CVE: CVE-2002-0985