JQuery 1.2 < 3.5.0 Multiple XSS

Medium Nessus Plugin ID 136929

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.8

Synopsis

The remote web server is affected by multiple cross site scripting vulnerability.

Description

According to the self-reported version in the script, the version of JQuery hosted on the remote web server is greater than or equal to 1.2 and prior to 3.5.0. It is, therefore, affected by multiple cross site scripting vulnerabilities.

Note, the vulnerabilities referenced in this plugin have no security impact on PAN-OS, and/or the scenarios required for successful exploitation do not exist on devices running a PAN-OS release.

Solution

Upgrade to JQuery version 3.5.0 or later.

See Also

https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/

https://security.paloaltonetworks.com/PAN-SA-2020-0007

Plugin Details

Severity: Medium

ID: 136929

File Name: jquery_cve-2020-11022.nasl

Version: 1.7

Type: remote

Published: 2020/05/28

Updated: 2020/09/08

Dependencies: 72816, 106658

Risk Information

Risk Factor: Medium

VPR Score: 3.8

CVSS Score Source: CVE-2020-11022

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: installed_sw/jquery

Excluded KB Items: Host/Palo_Alto/Firewall/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/04/10

Vulnerability Publication Date: 2020/04/29

Reference Information

CVE: CVE-2020-11022, CVE-2020-11023

IAVB: 2020-B-0030