JQuery 1.2 < 3.5.0 Multiple XSS

medium Nessus Plugin ID 136929


The remote web server is affected by multiple cross site scripting vulnerability.


According to the self-reported version in the script, the version of JQuery hosted on the remote web server is greater than or equal to 1.2 and prior to 3.5.0. It is, therefore, affected by multiple cross site scripting vulnerabilities.

Note, the vulnerabilities referenced in this plugin have no security impact on PAN-OS, and/or the scenarios required for successful exploitation do not exist on devices running a PAN-OS release.


Upgrade to JQuery version 3.5.0 or later.

See Also



Plugin Details

Severity: Medium

ID: 136929

File Name: jquery_cve-2020-11022.nasl

Version: 1.12

Type: remote

Published: 5/28/2020

Updated: 10/13/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 5.7


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2020-11022


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:jquery:jquery

Required KB Items: installed_sw/jquery

Excluded KB Items: Host/Palo_Alto/Firewall/Version, Host/Cisco/WLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/10/2020

Vulnerability Publication Date: 4/29/2020

Reference Information

CVE: CVE-2020-11022, CVE-2020-11023

IAVB: 2020-B-0030