PHP 7.4.x < 7.4.5 urldecode OOB Read

high Nessus Plugin ID 135969

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by an out-of-bounds read vulnerability.

Description

According to its self-reported version number, the version of PHP running on the remote web server is 7.4.x prior to 7.4.5. It is, therefore, affected by an out-of-bounds read error in urldecode() due to improper data validation checks. An attacker can exploit this, by inserting negative hex values to leak values that are found in the memory before the array.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.4.5 or later.

See Also

http://www.nessus.org/u?948f4dd6

http://www.nessus.org/u?a7727efb

Plugin Details

Severity: High

ID: 135969

File Name: php_7_4_5.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 4/24/2020

Updated: 5/22/2020

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2020-7067

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/16/2020

Vulnerability Publication Date: 4/16/2020

Reference Information

CVE: CVE-2020-7067

IAVA: 2020-A-0169-S