PHP 7.2.x < 7.2.30 Multiple Vulnerabilities

high Nessus Plugin ID 135926

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the version of PHP running on the remote web server is 7.2.x prior to 7.2.30. It is, therefore, affected by multiple vulnerabilities:

- An out-of-bounds read error exists in urldecode() due to improper data validation checks. An attacker can exploit this, by inserting negative hex values to leak values that are found in the memory before the array.
- A NULL byte injection vulnerability exists in shell_exec() and the backtick operator due to improper data sanitization.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.2.30 or later.

See Also

http://www.nessus.org/u?95070b64

http://www.nessus.org/u?80dcf021

http://www.nessus.org/u?7c83177f

Plugin Details

Severity: High

ID: 135926

File Name: php_7_2_30.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 4/23/2020

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2020-7067

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/16/2020

Vulnerability Publication Date: 4/16/2020

Reference Information

CVE: CVE-2020-7067

IAVA: 2020-A-0169-S