PHP 7.3.x < 7.3.17 Out of Bounds Read Vulnerability

high Nessus Plugin ID 135918
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.17. It is, therefore, affected by an out-of-bounds read error in its url decoding component due to insufficient validation of user-supplied input. An unauthenticated, remote attacker can exploit this, by sending specially crafted requests, to cause a denial of service (DoS) condition or execution of arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.3.17 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.3.17

Plugin Details

Severity: High

ID: 135918

File Name: php_7_3_17.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 4/23/2020

Updated: 5/22/2020

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2020-7067

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/16/2020

Vulnerability Publication Date: 4/16/2020

Reference Information

CVE: CVE-2020-7067

IAVA: 2020-A-0169-S