Palo Alto Expedition < 1.1.13 Cross-Site Scripting Vulnerability (PAN-SA-2019-0009)

medium Nessus Plugin ID 135277
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The reported version of Palo Alto Expedition is vulnerable to Cross-Site Scripting.

Description

A cross-site scripting (XSS) vulnerability exists in Palo ALto Expedition Migration Tool due to improper validation of user-supplied input before returning it to users. An authenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Solution

Update to Palo Alto Expedition version 1.1.13 or later.

See Also

https://security.paloaltonetworks.com/CVE-2019-1574

Plugin Details

Severity: Medium

ID: 135277

File Name: pan_sa_2019_0009.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 4/8/2020

Updated: 4/9/2020

Dependencies: palo_alto_expedition_web_detect.nbin

Risk Information

CVSS Score Source: CVE-2019-1574

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:paloaltonetworks:expedition_migration_tool

Required KB Items: installed_sw/Palo Alto Expedition

Exploit Ease: No known exploits are available

Patch Publication Date: 4/11/2019

Vulnerability Publication Date: 4/11/2019

Reference Information

CVE: CVE-2019-1574

BID: 107900