JQuery < 1.9.0 XSS

medium Nessus Plugin ID 135011

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

According to the self-reported version in the script, the version of JQuery hosted on the remote web server is prior to 1.9.0. It is, therefore, affected by a cross site scripting vulnerability.

Solution

Upgrade to JQuery version 1.9.0 or later.

See Also

https://nvd.nist.gov/vuln/detail/CVE-2012-6708

Plugin Details

Severity: Medium

ID: 135011

File Name: jquery_1_9_0.nasl

Version: 1.3

Type: remote

Published: 3/31/2020

Updated: 3/26/2021

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2012-6708

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/13/2012

Vulnerability Publication Date: 2/6/2012

Reference Information

CVE: CVE-2012-6708